Author Topic: Please help with Lyntin instalation.  (Read 1451 times)

0 Members and 1 Guest are viewing this topic.

Davy

  • Fodder
  • *
  • Posts: 57
Please help with Lyntin instalation.
« on: July 22, 2016, 05:45:30 PM »
So I bought a Mac after the sneaky bastards downloaded their new windows on my PC, bastards. Good bye Cmud. Anyways I have decided to mud again and have spent the past several days trying to install Lyntin without any sucess. I think I remember tintin++ script from 20 years ago and Lyntin sounded as a doable mud client if I can get it to work as a non programing, non mac using nitwit. This is what I have done so far. Downloaded Lyntin 4.2, downloaded Python, downloaded Pycharm. The install instructions are as follows however in my computer illiteracy I have no ideas what to do please help so I can play Arctic.
Thank you Davy.

=======
INSTALL
=======

:Author: Will Guaraldi
:Version: $Id: INSTALL,v 1.9 2007/09/30 02:02:50 willhelm Exp $


For more up-to-date documentation, check out the web-site at:
http://lyntin.sourceforge.net/



Summary
=======

This document holds installation instructions for various operating
systems as well as a series of general setup instructions for getting
started with Lyntin.

There are separate instructions for Unix/Linux and for Windows.  Read
the appropriate one for your system.


Easy-install
============

Requirements
------------

1. Python 2.3
2. setuptools (http://peak.telecommunity.com/DevCenter/setuptools)

Steps
-----

Run::

   easy_install lyntin


Lyntin takes both command-line options as well as a config file.  A
sample config file looks like this::

   [Lyntin]
   ui:        text
   datadir:   /home/willg/ltd40
   moduledir: /home/willg/ltd40
   readfile:  http://www.bluesock.org/~willg/3krc


To start Lyntin with the config file do this::

   runlyntin -c /path/to/config.ini

Lyntin takes a series of command-line options.  For a list of basic
options and explanations, run::

   runlyntin --help



Unix/Linux
==========

Requirements
------------

1. Python 2.2 (with Tkinter if you want to use the tkui)
   http://www.python.org/
2. tar
3. gzip


Steps
-----

Untar and unzip the client.  Then run::

   python setup.py install

That'll install the ``runlyntin`` script into ``/usr/bin`` or
``/usr/local/bin`` depending on how you have Python installed. 

Lyntin takes both command-line options as well as a config file.  A
sample config file looks like this::

   [Lyntin]
   ui:        text
   datadir:   /home/willg/ltd40
   moduledir: /home/willg/ltd40
   readfile:  http://www.bluesock.org/~willg/3krc


To start Lyntin with the config file do this::

   runlyntin -c /path/to/config.ini

Lyntin takes a series of command-line options.  For a list of basic
options and explanations, run::

   runlyntin --help


Windows
=======

Requirements
------------

1. Python 2.2 http://www.python.org/


Steps
-----

1. Make sure you have at least Python 2.2.
2. Run the installer which will install the Lyntin libraries and
   standard modules into the site-packages directory of your
   Python installation.
3. Download the startup script runlyntin.pyw from the website.
4. Adjust the boot settings in the startup script to suit your
   needs.


Conclusion
==========

If you have problems with installation, see the website on how to
contact us and ask questions.

Good luck!

the Lyntin development folks
http://lyntin.sourceforge.net/
 


gulca

  • Zone Leader
  • ***
  • Posts: 308
Re: Please help with Lyntin instalation.
« Reply #1 on: July 22, 2016, 11:37:50 PM »
you can run tintin++ on Mac console/terminal. all the scripts work.

unless you wanna muck in Python. can't help you here.

gnua

  • Zone Leader
  • ***
  • Posts: 393
Re: Please help with Lyntin instalation.
« Reply #2 on: July 29, 2016, 11:20:12 AM »
on a mac, i just brew install tintin

Malaki

  • Immortal
  • Newbie
  • *
  • Posts: 42
Re: Please help with Lyntin instalation.
« Reply #3 on: July 30, 2016, 02:59:34 PM »
Been using tintin++ for years, and i constaly hop back between linux and windows.  Pretty sure it runs just fine on mac, and i use the same config files with all my aliases triggers etc.

Dafin

  • Newbie
  • Posts: 5
Re: Please help with Lyntin instalation.
« Reply #4 on: August 01, 2016, 03:47:14 AM »
Lyntin is outdated and not supported for a long time. One can still run it on Python 2.7 but not Python 3.

It has some neat features but they are for advanced users imo.